Upgrade Dell EMC PowerFlex to v3.5

This guide provides the upgrade procedures for PowerFlex components. PowerFlex v3.5 must NOT be deployed on hyperconverged (HCI) configurations at this time. Please ask your account team to submit an RPQ using the following link to request PowerFlex v3.5 support for HCI.

https://inside.dell.com/docs/DOC-190638

The following table lists the upgrade support matrix:

Table 1. Upgrade support matrix
ScaleIO / VxFlex OS base version Upgrade path Supporting documentation
v2.0.1.4, 2.6.x Two-step upgrade flow:
  1. Upgrade to latest version of v3.0.1.x
  2. Upgrade to v3.5
Upgrade VxFlex OS to v3.0.x Guide

Upgrade PowerFlex to v3.5 Guide

v3.0, v3.0.0.x, v3.0.1.x Single-step upgrade from VxFlex OS v3.0/v3.0.0.x/v3.0.1.x to PowerFlex v3.5 Upgrade PowerFlex v3.5 Guide
NOTE: On ESXi-based PowerFlex v3.0, or v3.0.0.x systems that contain CentOS 7.5-based SVMs, the CentOS operating system must be upgraded after upgrade of system components.
NOTE: Upgrade of AMS managed PowerFlex systems to v3.5:

AMS is not supported on PowerFlex v3.5 and future versions. For guidance on AMS removal and the option to move to PowerFlex Manager please reach out to PowerFlex Product management.